La brève à laquelle vous répondez est recopiée en dessous de ce formulaire.

modération a priori

Ce forum est modéré a priori : votre contribution n’apparaîtra qu’après avoir été validée par un administrateur du site.

Qui êtes-vous ?
Votre message
  • Pour créer des paragraphes, laissez simplement des lignes vides.

Si vous donnez votre adresse de courriel dans ce formulaire, elle ne sera pas visible des autres visiteurs, mais uniquement par moi.


<   jeudi 23 mars 2006   >

Ubuntu a bien le package cups-pdf de Debian, il s’installe très facilement. Malheureusement, tel quel, il ne fonctionne pas. Pour le faire fonctionner, il faut changer son fichier de configuration et activer l’option RunAsUser.

On peut maintenant générer des documents PDF à partir de n’importe quelle application ... sauf Mozilla et ses dérivés (Firefox, Thunderbird) ! Pour eux, il faut encore modifier les options post script pour que le document post script envoyé à cups-pdf soit compréhensible. Sans cela, les documents PDF générés seront illisibles, vous n’y trouverez que les cadres et quelques lignes horizontales.

Pour ceux que ça intéresse, l’option que j’ai utilisée (dans propriétés de l’imprimante) est la suivante :

gs -q -sDEVICE=pswrite -sOutputFile=- -dNOPAUSE -dBATCH -dMozConvertedToLevel2=true - | lpr ${MOZ_PRINTER_NAME:+'-P'}${MOZ_PRINTER_NAME}

Elle permet de générer un document post script de niveau 2 qui est mieux reconnu par gs à qui cups-pdf fait appel.

< brève précédente    -    brève suivante >

plouf Creative Commons -  Espace privé -  XHTML -  CSS -  v1.1.3